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VISSIM Lab - Solving a Freeway Bottleneck 
CE 454: Urban Transportation Systems, Fall 2009 

Portland State University 
 

For this lab you will use VISSIM - a microscopic, time-step and behavior based simulation modeling software - to 
analyze a bottleneck at the Interstate 5 and Interstate 205 southbound (SB).  You should be aware that the purpose of 
this lab is not to teach you to be an expert in VISSIM but give you exposure to the techniques of coding, calibrating, 
and analyzing output from a simulation program.  This exercise will necessarily be a shortened version of what you 
would have to do if you were going to use the tool on an engineering project.  It is probably more important that you 
understand the building blocks of simulation presented in class rather than specific software. In practice, you will be 
expected to understand what the software is actually doing not just what the òblack boxó says.  
 
Learning Objectives 

V Be able to describe the basics of building a simulation model. 

V Be able to describe why it is important to calibrate models. 

V Analyze output generated by the software in an appropriate manner 

1 Exercise Description 
We will look at the freeway-to-freeway directional merge of I-205 southbound onto I-5 southbound. The project 
boundary will be from the Tualatin Sherwood to the merge of I-5 and I-205 SB. Note that we are only looking at 
southbound direction. The traffic volume at the SB merge of I-205 onto the I-5 mainline is sufficient most (but not 
all) days to create a bottleneck that persists both on the I-205-to-I-5 ramp and on I-5 itself.  In your simulation (after 
the warm up period) you should see queues forming in the animations. Because of the high quality aerial photographs 
it is helpful to use Google Maps (maps.google.com) to view the study area. The geometry (primarily the number of 
lanes and locations of merge points) is of particular interest.  We suggest that you make notes on the 8x10 project 
map about the geometry of the southbound project limits. There are two locations to note since they are little unusual 
and key to getting the model correct and are shown in Figure 1. 
 
The following is provided: a scaled aerial photograph for creating the network, traffic volumes during the peak period, 
and distribution of traffic for routing purposes, and an 8x10 map handout. These data are contained in this lab 
document and on the class web site.  Using VISSIM you will: 
 

V Create a model of the existing conditions; 

V Calibrate the network; 

V Obtain a measures of existing performance; 

V Make a modification to the network that might (or should) improve the interchange such as, but not limited 
to: 

o adding more through lanes 
o adding a longer acceleration lane 

V Compare selected measures of effectiveness for the two outcomes.  
 
 
 

http://maps.google.com/maps?ie=UTF8&ll=45.373373,-122.759943&spn=0.0533,0.088749&t=h&z=14
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Figure 1: Merges along I-205 SB ramp to I-5 

2 Getting Started 
Below are some tips you should know before starting the lab: 

 Draw links and connectors in the direction of travel 

 Name each link that you create in a logical manner (see labels of links shown in the following screen capture) 

 Lanes are numbered with 1 being the far right lane 

 Add òVehicle Inputsó after all links and connectors and routes have been drawn. 

 Add òRoutesó after you have drawn all links and connectors 

 Save your work periodically 

2.1 Set Up Project Files 

Go to your N:drive and create a directory called òVISSIMLabó. All files that VISSIM creates from the analysis will be 
saved in these working directories. You should create 2 subfolders one called òBaseó and one called òModifiedó.  
From the class web calendar page, download the zip file, unzip in the main directory. 

2.2 VISSIM Interface 

Open VISSIM 5.10 by going to Start > All Programs > PTV_Vision > VISSIM 5.10 > VISSIM 5.10.  The VISSIM 
interface is generally straightforward after you figure out a few quirks of inputting data.  As shown in the following 
screen capture, all of network editing tools are on the left menu. Each icon refers to various network editing 

2 lanes can exit I-5 

The ramp goes from 2 
lanes to 1 before the 
merge with I-5SB 

http://web.cecs.pdx.edu/~monserec/courses/urbantrans/calendar.htm
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capabilities (links, routes, traffic volumes, speed reduction areas, etc). Mousing over them tells you what they do.  The 
menus across the top control the simulation inputs and settings.  The help is ò?ó. 
 

  

2.3 Change Units to English 

 Change Units from Metric to English  

 Go to View > Options > Language and Units 

 Change all of the units to English and click OK 

This area tells you what 
VISSIM is expecting from 
you next from the mouse 
or keyboard. 

These are the network 
construction icons. These 
can be toggled at any time. 
This is pointing to the 
network link connector icon 

These menu items control 
the simulation settings and 
file management 

Help 

These icons let you zoom 
and scale the network.  
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2.4 Import Background  Image 
A quick way to construct a network is to draw over the top of an aerial photograph. To do this 

 Bring in the background map by selecting from the main menu: View > Background > Edit 

 
 Click Loadé and select background file (i5205.bmp) from location you downloaded from the class web. 

2.5 Setting the Scale 
The background map has to be scaled to get accurate results. Ideally you would know the actual scale of the drawing 
but for our purpose we will just scale off of two points where the distance is known. While this isnõt very precise, it is 
good enough for this exercise.  In this example we have used Google maps1 to find the distance from the overhead 
sign gantry south of the Tualatin Sherwood/Nyberg interchange overpass to the Sagert Street overpass as shown in 
the following screen capture. The distance is 1206.93 feet. 

                                                           
1 If  you want to get your own measurement, visit Google Maps: maps.google.com and click on the  My Maps link, 
then choose the Distance Measurement Tool 
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To add the scale to VISSIM, select View, Background, Edit then Click on Scale. Using the ruler do the following: 

 The image will be really small in the bottom left corner. Hold the scroll on your mouse to navigate around. 
Scrolling up will zoom in. Scrolling down will zoom out. 

 You will see a ruler. Find the same two points as in Google Maps.  

 Find starting point, then click and hold left mouse button 

 Drag ruler to the second point 

 Release left mouse button 

 Enter distance in feet, click OK.  
 

Itõs a good idea to save your file now. File > Save As > in the òBaseó folder.  

3 Creating the Network 
Creating the network involves adding links and connectors to build the roadway being modeled. The network will also 

identify the routing options for drivers. Later, you will modify driver behavior such as lane changes, headway, 

acceleration, and deceleration.   

Always draw Links and Connectors in the direction of travel.  

3.1 Creating Links 

Click in the toolbar on the Links and Connectors icon.  Start from the north and work your way down the 
network (in the direction of travel). Drawing a link is simple once you get the hang of it but it involves left and right 
mouse clicks. Be sure to watch the status bar for a clue on what VISSIM is expecting next. We will show you first how 
to draw straight links (then we show you how to change alignment in the next step). Letõs draw the first link of I-5 
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from the top to just before the Tualatin Sherwood on-ramp. Note we are going to ignore the off-ramp at this location 
since it does donõt affect our bottleneck area. To draw a link: 

 Place cursor over starting point for the link (shown as 1 on the 8x10) 

 Click right mouse button and hold  

 Drag cursor to approximately the point where I-5 and the Tualatin Sherwood on-ramp intersect (shown as 2 
on the 8x10) 

 Release right mouse button, after which this window will appear:

 
 Your òLink Lengthó will vary from the 3765.144 ft shown above. 

 You should name the link in a systematic manner. 

 For the options, Select Behavior type  
o 2. Freeway (free lane selection).  
o The number of lanes to 3 (remember weõre only looking at the SB direction) 
o Lane width = 12 ft 
o All other defaults are good. 

 Click OK and the link information is saved. 

3.2 Add Lane Markings 

Lane markings are an easy way to see the number of lanes on your link segments. They are also an aesthetic way to 

ensure your links line up evenly. To make lane markings visible, do the following: 

 Go to View > Options > Network 

 In òLane marking (width)ó change the number to 1 pixel. You can use any value but 1 works best. 
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3.3 Adding the first on-ramp 

At the Tualatin-Sherwood on-ramp, create a link such that it almost connects to I-5 but leave a small gap as shown in 
the following figure. Make sure that the two links do not meet, but come close.  Before we connect the two links, we 
will first construct the next downstream link. Then join the 3 links with 2 connectors.  

Links are connected to one another by connectors 
 

 

3.4 Changing the alignment of a link 

Not all links will be perfectly straight. The on-ramp you just drew has some curvature to it. Fortunately it is easy to 
adjust the links so that they align with the geometry on the aerial photograph. To add curvature to a link, do the 
following: 

 Double click on link to be edited 

 Single right click anywhere on the link where you want to shift the alignment. A vertex will appear. Now left 
click on the node and drag the new node to create a curve. 
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 Repeat by right clicking again to add more vertices as necessary. 

3.5 Adding the next downstream link 

Create the next I-5 mainline link south (below) the on-ramp and I5 link already created. Hopefully you noticed in your 
inspection of the geometry that this section has 4 lanes. For the other options, select all of the same options as in 3.1. 
 

 

3.6 Connectors 

This is a very important step in building a network in VISSIM. Links need to be connected to other links. It is 
not sufficient to place one link on top of another link in order for vehicles to continue on the other link. Instead, a 
connector needs to be created to connect the two links.  We will be able to assign properties to these connectors. For 
computational reasons, it is best to keep connectors as short as possible. These connectors guide the paths of vehicles 
and other simulation properties. 

It is important to remember that all connectors are drawn in the direction of travel. 

 To create a connector, click on the Links and Connectors icon. You will create two connectors, one for 
the on-ramp to the downstream link and one for the mainline to the downstream link. 

 Start by clicking on the ramp 

 In the same way you made a link, draw a connector from the ramp to the mainline in the direction of travel. 

 A dialog box will appear. Lanes are numbered with 1 being the right-most lane. To make the connector work, 
you need to indicate the how the vehicles from the ramp enter in to the downstream link. Clearly, lane 1 
connects with lane 1.  
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 Repeat for the mainline connector. Notice that you connect lanes 1,2,3 on the upstream link to lanes 
2,3,4 on the downstream link.  

 For this connector all defaults are adequate. We will come back to changing a few other values later. 
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Repeat this process of building link and connectors to create the network.  Sections 3.7, 3.8, and 3.9 will guide you 
through some of the more complicated parts of the network. 

 

3.7 First Exit Ramp 

The first exit ramp (diverge section) from I-5 SB is the I-205 NB exit ramp. The construction of these links will be 

similar to a merge area but opposite.  

 Extend the 4-lane section to just a point just before the exit ramp shown as point 3 on the 8x10. 

 Construct the links for the diverge area as shown in the screenshot below. 
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These links will be connected with connectors. To do this: 

 Draw the first connector from the I-5 mainline to the I-205 NB off-ramp. Notice that lanes 1 and 2 from I-5 

connect to the I-205 off-ramp. 

 

 Repeat for building the connector from the I-5 four-lane section to the through I-5 link. 
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From your inspection of the lane geometry on Google Maps, you should see that Lane 2 is a through movement and 

an exit movement. Notice how in the above image, lanes 2,3, and 4 connect to lanes 1,2, and 3. 

 

Continue to draw the network. 

3.8 Lane Drop  
You may have noticed from your inspection on Google Maps that the I-205 SB ramp goes from 2 lanes to 1 lane 

before merging with I-5SB. This is a lane drop. To construct the lane drop: 

 Draw the 2-lane section up until the lane drop at point 4 on the 8x10. 

 Draw the 1-lane section. 

 It should look like the image below. 
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 Connect them with a connector. 

 

 The following screen appears.  

 Make sure that òLane 2ó of the two lane section connects with òLane 1ó of the one lane section.  


