Overview

This document gives step-by-step instructions for simulating heat transfer from a heated patch on the wall of a rectangular duct.

Physical Problem

Figure 1 is a schematic of the duct with the patch mounted flush on the bottom wall. To model the effect of conduction in the bottom wall, a layer of solid material of thickness $h$ is included. The model will involve heat transfer in the flowing fluid that is coupled to heat conduction in the solid. This type of problem is known as conjugate heat transfer. The heated patch is modeled with a layer of baffle cells on the interface between the fluid and solid.

The geometrical parameters used in this cookbook are

$$b = 3\, \text{cm} \quad W = 12\, \text{cm} \quad H = 6\, \text{cm} \quad L = 21\, \text{cm}$$

Figure 1: Schematic of heated patch in a rectangular duct.
The thermal and flow parameters are

\[ U_{in} = 2 \text{ m/s} \quad T_{in} = 20^\circ C \quad Q = 2 \text{ W} \]

We assume that the temperature distribution in the fluid is such that we can neglect property variations. This is an approximation, but a very helpful one as it allows us to solve the flow field independently of the temperature field. In fact, if we present the results in terms of heat transfer coefficients (and Nusselt numbers), the magnitude of the power input does not matter.

To specify the boundary conditions in Star-CD, the total heat transfer rate needs to be converted into a heat flux. For the \( b \times b \) heated patch, the heat flux is

\[ q = \frac{Q}{b^2} = \frac{2 \text{ W}}{9 \text{ cm}^2} = 0.2222 \text{ W/cm}^2 = 2222 \text{ W/m}^2 \]

The solution will be obtained for two wall materials: Acrylic (e.g. Plexiglass\textsuperscript{TM}) and 2024-T6 Aluminum

- Acrylic: \( k_w = 29.9 \text{ W/m} \cdot \text{K} \)
- Aluminum: \( k_w = 177 \text{ W/m} \cdot \text{K} \)

The hydraulic diameter of the duct is

\[ D_h = \frac{4 WH}{2(W + H)} = 8 \text{ cm} \]

The kinematic viscosity of air at \( 20^\circ C \) is \( \nu = 1.51 \times 10^{-5} \text{ m}^2/\text{s} \), so the Reynolds number of the flow based on hydraulic diameter of the duct is

\[ Re_{D_h} = \frac{U_{in} D_h}{\nu} = \frac{(2 \text{ m/s}) (0.08 \text{ m})}{1.51 \times 10^{-5} \text{ m}^2/\text{s}} = 10600 \]

Therefore, the flow is turbulent.

**Create the Mesh**

The mesh for this problem consists of two regions, one for the fluid and one for the solid. The vertices at the interface are coincident, so no mesh couples are needed. The physical problem is symmetric about the center of the duct, so the half-duct model is built by using a vertical symmetry plane.

Better accuracy can (and should) be obtained by using a finer mesh near the patch and in the wake of the patch. A uniform, medium fine mesh is used in this cookbook in order to keep the mesh generation simple.

**Prepare for Model Building**

1. Create a new working directory in the Windows environment
2. Start the Star-CD Launcher and set the working directory
3. Launch Prostar
   - Create a new case name, e.g., `patchInDuct`
4. Create a title for the model
   a. From the menu bar of the Prostar window: **File → Model Title**
   b. Enter a descriptive title such as “Convective heat transfer from a heated patch”
   c. Click **Apply**
Mesh Generation

The mesh generation for this model consists of four primary tasks

1. Creation of the mesh in the fluid
2. Creation of the mesh in the solid
3. Creation of the baffle cells to model the heater patch
4. Merging coincident vertices to create a unified model that includes the fluid and solid.

The mesh dimensions will be specified in millimeters.

Fluid Zone Mesh Generation

1. Open the *Create 3-D Grids using Simple Shapes* panel in the Star GUIde NavCenter.
   
   *Create and Import Grids*
   
   → *Create Grids*
   
   → *Create 3-D Grids using Simple Shapes*

2. Verify that the coordinate system is Cartesian, and that the material type is 1 (Fluid).

3. In the *Extent of Domain* region at the right side of the NavCenter window, enter the following values in the boxes.

<table>
<thead>
<tr>
<th>Minimum</th>
<th>Maximum</th>
<th>Number of Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0</td>
<td>210</td>
</tr>
<tr>
<td>Y</td>
<td>0</td>
<td>60</td>
</tr>
<tr>
<td>Z</td>
<td>0</td>
<td>60</td>
</tr>
</tbody>
</table>

4. Click *Generate Mesh* at the bottom of the right side of the NavCenter window.

Solid Zone Mesh Generation

1. Return to the *Create 3-D Grids using Simple Shapes* panel in the Star GUIde NavCenter.

2. Click *Select a Coordinate System*

   a. Select the first empty number in the coordinate system list
   b. At the bottom of the window, select *Cartesian* from the pop-up menu
   c. In the first three boxes next to *Cartesian* at the bottom of the window, enter the x, y, z offsets of the new coordinate system

   | Cartesian | 0   | 0   | -5 |

   d. Click *New Global*
   e. Click *Set Active*
   f. Click *Close*

3. Create a solid cell type for the duct bottom wall
   
   a. Open the *Cell Tool* in the Prostar Display window:
Tools → Cell Tool...

b. Click Edit Types...

i. In the cell table list in the left hand side of the Cell Table Editor window, click on the first row (4) having an empty “Type” entry.

ii. In the Cell Table Editor enter the following data for the solid cells

<table>
<thead>
<tr>
<th>Cell Type</th>
<th>Solid</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material Number</td>
<td>2</td>
</tr>
<tr>
<td>Color Table Index</td>
<td>7 (cyan)</td>
</tr>
<tr>
<td>Group</td>
<td>1</td>
</tr>
<tr>
<td>Name</td>
<td>DuctBottomWall</td>
</tr>
</tbody>
</table>

The group number will allow selection of cells in the solid and heater patch (to be defined later).

iii. Click Apply

iv. Close the Cell Table Editor

4. Return to the Create 3-D Grids using Simple Shapes panel in the Star GUIde NavCenter.

5. Click Select Cell Type to verify that the newly created material type (Material 2, Solid) is selected

6. In the Extent of Domain region at the right side of the NavCenter window, enter the following values in the boxes.

<table>
<thead>
<tr>
<th>Minimum</th>
<th>Maximum</th>
<th>Number of Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0</td>
<td>210</td>
</tr>
<tr>
<td>Y</td>
<td>0</td>
<td>60</td>
</tr>
<tr>
<td>Z</td>
<td>0</td>
<td>5</td>
</tr>
</tbody>
</table>

7. Click Generate Mesh at the bottom of the right side of the NavCenter window.

Create Baffle Cells to Model the Heater

The baffle cells model the $3 \times 1.5$ mm (half) heater patch at the interface between the solid and the fluid. The baffle cells are attached to the top surface of the solid cells with vertices in the range $60 \leq x \leq 80$ mm, $0 \leq y \leq 15$ mm. To expose the faces one can use the mouse to create a cell set consisting of the solid cells in that range. This requires careful counting of the cells (which were defined with a spacing that fits the edges of the heater). An alternative procedure is to use a Prostar command to specify the range of $(x, y, z)$ values to select the cells. We use the Prostar command, here.

1. Create a baffle cell type for the heater

   a. Open the Cell Tool in the Prostar Display window:

       Tools → Cell Tool...

   b. Click Edit Types...

       i. In the cell table list in the left hand side of the Cell Table Editor window, click on the first row (5) having an empty “Type” entry.

       ii. In the Cell Table Editor enter the following data for the baffle cells
Cell Type      Baffle
Material Number 2
Color Table Index 13 (purple)
Group 1 (same as solid bottom wall)
Name heater

iii. Click **Apply**
iv. **Close** the Cell Table Editor

2. Create a cell set that contains only the solid cells below the heater. In the Prostar Command Window, enter the following statement

```cset news grange 59.9, 80.1, 0, 15.1, -50.1, 0, 1```

Note that the dimensions are in millimeters. Also note that the range of \((x, y, z)\) values are slightly larger than the range of vertex locations. The slightly enlarged range guarantees that rounding errors in the vertex locations will not cause cells to be missed in the selection.

3. Orient the model so that the top face of the cells is visible. In the Prostar Display Window select

![View > Axis → +Z](image)

4. Apply the baffle cells to the tops of the solid cells

a. Open the **Cell Tool**: In the Prostar Display Window Select **Tools → Cell Tool...**

b. Select table entry # 5 (Baffle), and click **Set Active Type**

c. Use the **Add Baffles** button (red button below the cell table list) to attach the baffle cells

![Add Baffles → Zone](image)

Use the mouse to trace a rectangular region that encloses the face of all visible cells. Click **Done**.

5. Verify the location of the baffle cells on the solid

a. Select cells in Group 1 (solid and baffle). Using the **Cell Set** button on the left edge of the Prostar Display Window, select

![G -> New -> Group...](image)

The cursor turns into a cross-hair. Click on any baffle or solid cell visible in the window.

b. Click **Cell Plot**

c. The result of the preceding cell selection and plot steps should show the (purple) heater at the correct location on the solid. See Figure 3 on page 9. If the heater is not located correctly, delete the heater cells using the steps below.

6. **Only if the preceding baffle cell creation step fails**, delete the baffle cells and try again. Otherwise, proceed to vertex merge step, below.

Baffle cell deletion:

a. Select (all of) the current baffle cells. Using the **Cell Set** button on the left edge of the Prostar Display Window, select
Figure 2: Edge plots to display the model before (above) and after (below) the merging of vertices.

- **C —> New —> Baffle**
  
  - Delete the cells by entering the following command in the Prostar Command Window:
    ```
    cdel cset all
    ```
  
  - Return to Step 2, above to begin recreation of the baffle cells.

**Merge Coincident Vertices**

1. Create an edge plot to view cracks in the model

   - In the Prostar Display Window, create a cell set of all cells in the model:
     ```
     C —> All
     ```
   
   - Click [Cell Plot]
c. Click the Edge Display button on the upper part of the left edge of the Prostar Display Window. The display should look like that in upper half of Figure 2.

2. Open the Assemble Grids panel in the Star GUIde NavCenter

   Create and Import Grids → Assemble Grids

3. Merge all vertices that are within 0.05 mm of each other.
   a. Select the Vertex Merge tab
   b. Click All Vertices
   c. Keep Low
   d. Set the tolerance to 0.05
   e. Click Merge

4. Verify the merge operation
   a. Visually inspect the mesh by clicking Replot. The result should be that in the lower half of Figure 2. All edges should disappear except the bounding edges, and a single line parallel to the x axis at the interface between the solid and fluid.
   b. Check for cracks with the Check Grid panel of the Star GUIde NavCenter.

   Check and Fix Grid → Check Grid
   i. Select the Cracks option in the pop-up menu for the Check Option
   ii. Leave the default settings for the other check parameters, and click Apply at the bottom of the panel.
   iii. Inspect the result of the check that is displayed in the Prostar Command Window. There should be no cracks.

Save the Model

   File → Save Model

   Remember to copy your .mdl file back to a private directory before logging off your workstation!
Assign Material Properties

Turn on Conjugate Heat Transfer

1. Open the Thermal Options panel of the Star GUIde NavCenter

   Thermophysical Models and Properties → Thermal Options

2. At the bottom of the panel, turn the Conjugate Heat Transfer switch On

3. Leave the Solid Underrelaxation Factor set to 1

4. Click [Apply]

5. Notice that additional panels for Solids and Porosity have appeared under the Thermophysical Models and Properties heading of the Star GUIde NavCenter.

Set Fluid Properties

1. Verify that the fluid is air at standard conditions for this model. Open the panel for specifying the molecular properties of air in the Star GUIde NavCenter:

   Thermophysical Models and Properties → Liquids and Gases → Molecular Properties

   Note that the Material number is 1 at the bottom of the page

2. Turn on the $k - \epsilon$ turbulence model on:

   Thermophysical Models and Properties → Liquids and Gases → Turbulence Models

   a. Click On. This opens up the turbulence model specification panel.
   b. Select the Turbulence panel
   c. Select K-E/High Reynolds Number from the pop-up menu for the Turbulence Model
   d. Notice that the selection applies to Material #1 (Air)
   e. Click Apply

3. Turn on thermal modeling for air:

   Thermophysical Models and Properties → Liquids and Gases → Thermal Models

   a. Set the Temperature Calculation On button.
   b. Notice that the selection applies to Material #1 (Air)
   c. Click Apply
Figure 3: Cell set consisting of fluid and baffle cells, viewed from below.

4. Verify that buoyancy is turned Off:

   *Thermophysical Models and Properties*
   
   → Liquids and Gases
   
   → Buoyancy and Body Forces

5. Specify Location of the monitoring cell for the fluid.

   *Thermophysical Models and Properties*
   
   → Liquids and Gases
   
   → Monitoring and Reference Data

a. Prepare the cell selection by creating a cell set that consists of only the fluid and the baffle cells.

   i. Turn off edge plotting.
   
   ii. Click [Cell plot] If cells in the fluid volume do not appear, create a cell set of all cells in the model.

   C → All

   iii. Create a new cell set that consists only of the fluid cells

   C → New → Material...

   The cursor turns into a cross-hair. Click on any fluid cell.

iv. Click [Cell plot]

v. Add the baffle cells to the current cell set

C → Add → Baffle

vi. Click [Cell plot] Rotate the model so that a view similar to that in Figure 3 appears.

b. Return to the Monitoring and Reference Data panel in the Star GUIde NavCenter.
Set Solid Properties

1. Define the material properties for the solid
   a. Open the Material Properties panel for the solid
      \( \text{Thermophysical Models and Properties} \rightarrow \text{Solids} \rightarrow \text{Material Properties} \)
   b. Adjust the slider so that the material # is 2
   c. Type in the following values (replacing the property data for steel)
      
      \[
      \begin{array}{ll}
      \text{Name} & \text{Acrylic} \\
      \text{Density} & 1170 \text{ kg/m}^3 \\
      \text{Conductivity} & 29.9 \text{ W/m/K} \\
      \text{Specific Heat} & 1465 \text{ J/kg/K} \\
      \end{array}
      \]
   d. Click Apply

2. Specify Location of the monitoring cell for the solid

3. Open the Monitoring and Reference Data panel for the solid
   \( \text{Thermophysical Models and Properties} \rightarrow \text{Solids} \rightarrow \text{Monitoring and Reference Data} \)
   a. Prepare the cell selection by creating a cell set that consists of only the solid and the baffle cells.
      i. Turn off edge plotting (if it is on).
      ii. Click [Cell plot] If cells in the solid volume do not appear, create a cell set of all cells in the model.
Figure 4: Cell set consisting of fluid and baffle cells, viewed from above.

iii. Create a new cell set that consists only of the solid cells

\[ \text{C} \rightarrow \text{New} \rightarrow \text{Material...} \]

The cursor turns into a cross-hair. Click on any solid cell.

iv. Click \[ \text{Cell plot} \]

v. Add the baffle cells to the current cell set

\[ \text{C} \rightarrow \text{Add} \rightarrow \text{Baffle} \]

vi. Click \[ \text{Cell plot} \]. Rotate the model so that a view similar to that in Figure 4 appears

b. Return to the Monitoring and Reference Data panel in the Star GUIde NavCenter

Thermophysical Models and Properties
\rightarrow \text{Solids}
\rightarrow \text{Monitoring and Reference Data}

c. To the right of the text box labeled Monitoring Cell Number, click on the button that looks like a computer mouse. This activates the cross-hairs in the Prostar Display Window. Click on a cell in the \( z = 0 \) plane, and downstream of the heated patch.

d. Return to the Monitoring and Reference Data panel.

e. Check (at the bottom of the Monitoring and Reference Data panel) that the Material is \#2 (Acrylic)

f. Click Apply.

Save the Model

In the menus for the Prostar Display window:

File \rightarrow \text{Save Model}


Locate Boundary Regions

Use the Create Boundaries panel in the Star GUIDe NavCenter to create the boundary regions. There are four boundary regions in all

1. inlet
2. outlet
3. baffle
4. symmetry

Inlet and Outlet

It is extremely important that the inlet and outlet are imposed on only the fluid cells. These boundary creation steps will be easier if a cell set consisting only of fluid cells is created first:

\[ \text{C} \rightarrow \text{New} \rightarrow \text{Fluid} \]

After making this selection, click Cell Plot to refresh the Prostar Display Window. With this cell set selected, open the Create Boundaries panel,

Locate Boundaries \rightarrow Create Boundaries

and define the following boundary regions:

- Inlet on the fluid cell faces at the \( x = 0 \) plane.
- Outlet on the fluid cell faces at the \( x = x_{\text{max}} \) plane.

Note: If the Plot Region Boundaries button or Plot All Boundaries button is selected during the boundary definition phase, Prostar reverts to a cell set containing all cells in the domain. Thus, before any new (inlet or outlet) boundary is selected, be sure to reset the current cell set to all fluid cells.

\[ \text{C} \rightarrow \text{New} \rightarrow \text{Fluid} \]

Baffle

Create a cell set consisting of only baffle cells

\[ \text{C} \rightarrow \text{New} \rightarrow \text{Baffle} \]

After making this selection, click Cell Plot to refresh the Prostar Display Window. With this cell set selected, open the Create Boundaries panel,

Locate Boundaries \rightarrow Create Boundaries

and define the baffle boundary regions on the baffle cells used to model the heater.
Symmetry

The symmetry boundary must be applied to both the fluid and solid cells. To achieve this boundary creation step the current cell set must contain all cells in the model

\[ C \rightarrow \text{All} \]

Click [Cell Plot] to refresh the Prostar Display Window. With this cell set selected, open the Create Boundaries panel,

\[ \text{Locate Boundaries} \rightarrow \text{Create Boundaries} \]

and define a symmetry boundary region on the entire \( z = 0 \) plane.

Assign Values to Boundary Conditions

1. Open the Define Boundary Regions panel in the Star GUIde NavCenter

\[ \text{Define Boundary Conditions} \rightarrow \text{Define Boundary Regions} \]

2. Select the Inlet boundary from the list of boundary regions.
   a. Set \( U = 2, V = 0, W = 0 \)
   b. In the pop-up menu for Turb. Switch, select TE/Length. In response to the pop-up window, click Yes to the question about changing to Turbulence Intensity and mixing length for all boundary conditions.
   c. Enter 0.02 for the Turb. Intensity and 0.005 (m) for Length
   d. Click Apply

3. Select the outlet boundary surfaces.
   • Select the Standard Option
   • Verify that the Flow Split is 1.
   • Click Apply

4. Check the boundary settings for the symmetry surface. Accept the default values. Make sure the Standard Option is selected.

5. Select the baffle boundary surfaces.
   • Select the Standard Option
   • Verify that the no-slip option is selected
   • Verify that velocities on side (1) are all 0
   • Leave the \( A_{\text{res}} \) and \( B_{\text{res}} \) parameters set to 1.e+30
     \( A_{\text{res}} \) and \( B_{\text{res}} \) control the porosity of the baffle as described in Chapter 8 of the Star Methodology Manual [1], especially Equation (8-6). See also [2, p. 7-31]. For a solid baffle, \( A_{\text{res}} \) and \( B_{\text{res}} \) must be very large values.
   • Leave Porosity set to 0
   • Leave the Roughness set to Standard

The standard wall function model uses the parameter \( E_{\text{log}} \) (see below) to characterize the roughness.
• Leave $E_{\log}$ set to 9

$E_{\log}$ is a wall function parameter that varies with wall roughness. $E_{\log} = 9$ for a smooth wall. See [1, Chapter 6], especially Equation (6-3) and [2, Chapter 7], especially pp. 7-25 through 7-26.

• Set the Wall Heat pop-up menu to Flux
• Enter 1111 in the Heat Flux box
• Click Apply
• Repeat the settings for side 2, including a value of 1111 in the Heat Flux box.
• Click Apply

Save the Model

In the menus for the Prostar Display window:

File → Save Model

Set Solution and Output Controls

The default solution controls are appropriate. Verify the solution controls settings with the following steps.

1. Bring the Star GUIde window into focus by clicking on its title bar
2. Open the Solution Method panel:

   Analysis Controls → Solution Controls → Solution Method

3. Verify that the model will obtain a Steady State solution using the SIMPLE algorithm
4. Inspect the Equation Behavior panel

   Analysis Controls → Solution Controls → Solution Method → Equation Behavior

5. Verify that $U$, $V$, and $W$ velocity components, the pressure $P$, and the turbulence variables $k$ and $\epsilon$, are selected for solution.

6. If any changes are made, click Apply.

The Star flow solver will run until the solution converges, or until the maximum number of iterations are reached. To help insure that a converged solution is obtained, set the maximum number of iterations to a suitable value.

1. Bring the Star GUIde window into focus by clicking on its title bar
2. Open the Run Time Controls panel:

   Analysis Preparation/Running → Set Run Time Controls

3. Enter 200 in the text box for Number of Iterations. If this is not enough iterations to guarantee convergence, restart the solution.

4. Click Apply.
Check the Model

It is a good idea to take advantage of built-in model checking features of Star-CD

1. Bring the Star GUIde window into focus by clicking on its title bar
2. Open the Check Everything panel:
   
   Check Model Setup → Check Everything
3. Click the All button at the bottom of the panel.
4. Open the I/O window (underneath the Prostar Display Window) to view the results of the model checks. Verify that the model parameters are consistent with your boundary conditions, cell definitions, etc.

Save mdl and geom Files

The final stage of model preparation is to write the .geom and .prob filesthatareadbytheStar flow solver.

1. Bring the Prostar Display window into focus by clicking on its title bar
2. In the menu bar of the Prostar Display window, select
   
   File → Write Geometry File
3. Inspect the file name and directory. The file name should have the same base name as the .mdl file you have been saving. The base name for the file is the case name in the dialog box that appears when Prostar is first launched. (patchInDuct for this cookbook example)
4. Change the Scale Factor is 0.001. This is necessary because the model was built in Prostar using lengths in millimeters. The model solution in STAR is always in SI units, where the lengths are meters.
5. Click Apply.
6. Click Close.
7. In the menu bar of the Prostar Display window, select
   
   File → Write Problem File
8. Click Apply.
9. Click Close.

Save the Model

In the menus for the Prostar Display window:

   File → Save Model
Solve with STAR

1. In the Star-CD Launcher applet select Star Solve → Star

2. At the command window prompt, enter the case name, e.g. patchInDuct, and press the return key.

Post-Processing

1. Inspect the solution history.

2. Plot velocity vectors on planes cut through the solution domain.

3. Plot contours of the pressure.

4. Plot contours of the temperature. See Figure 5 and Figure 6.

5. Plot contours of turbulence kinetic energy. (boring)

References


Figure 6: Temperature field of the patch on a horizontal ($x, y$) plane through the patch.