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Analog Artist Tutorial

This tutorial is designed to introduce you to the tools we will use in ECE 746.  It will introduce
you to the Cadence Environment, specifically Composer, Analog Artist and the Results
Browser.

The following typeface and color conventions will be used in this document:
� General Text: add cadence
� Commands / Menu Selections:  add cadence
� Screen Output:  add cadence

1. Starting the Cadence Environment:
% add cadence

Use the following commands to start Cadence applications:

    openbook      Cadence online documentation

    icde &        Basic digital and analog design entry
    icds &        Front end design
    icms &        Front end analog, mixed signal and microwave design
    icca &        Cell based chip assembly
    layout &      Basic layout with interactive DRC
    layoutPlus &  Basic layout plus automated design tools
    msfb &        Mixed-signal IC design
    icfb &        Front to back design

    spectre <input file> &      Spectre circuit simulator
    verilog <input file> &      Verilog HDL simulator
    signalscan &                Analog/digital waveform display

We are now using version 4.4.5 of the Cadence IC tools. If
you require version 4.4.2, please type "add cad442" instead.

Problems with the tools? Wondering where SimWaves went? Check the FAQ at

              http://www.ece.ncsu.edu/cadence/doc/cdsuser/
 
% mkdir Artist
% cd Artist
% icfb &

A few seconds later, you'll see CIW (Command Interpreter Window) and Library Manager
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2. Create a Design Library:

      In Library Manager, Click File -> New -> Library
      In the Name field, enter “ArtistTutorial”
      In the Technology Library box, select

Attach to existing tech library  -> TSMC 0.30u
Press OK
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Then the Library Manager will refresh as follows:

3. Create a Schematic:
     
In Library Manager, select ArtistTutorial  
From the Menu Bar, select File -> New -> CellView

      Fill the Form as follows, then click OK
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A blank Schematic window will then appear.
We need to generate a schematic as shown below:

To generate a schematic like this, you will need to go through the following steps:

From the Schematic Window menu, select Add -> instance
The Component Browser, will then pop up.
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In the Library field, select NCSU_Analog_Parts
We will place the following instances in the Schematic Window from the
NCSU_Analog_Parts library as instructed below:
 

N_Transistor : nmos
 P_Transistor : pmos
 Supply_Nets : vdd , gnd
 Voltage_Sources : vdc,vpulse
 R_L_C : cap

Note: pay attention to the parameters specified in  vdc, vpulse, and cap. These parameters are
very important in simulation
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A. Place pmos instance:

In Component Browser, select P_Transistor and then pmos 
Place it in the Schematic Window

 

B. Place nmos instance:

In Component Browser, select N_Transistor and then nmos
Place it in the Schematic Window
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C. Place gnd instance:
    

In Component Browser, select Supply_Nets and then gnd
Place it in the Schematic Window

 

D. Place vdd instance:
    

In Component Browser, select Supply_Nets and then vdd
Place it in the Schematic Window



9

E. Place IN pin:
      

From the Schematic Window menu, select Add -> Pin...
      In the Pin Name field , enter “IN”
      In the Direction field, select input

Place it in the Schematic Window
 

F. Place OUT pin:
      

From the Schematic Window menu, select Add -> Pin...
      In the Pin Name field , enter “OUT”
      In the Direction field, select output

Place it in the Schematic Window
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G. Place vdc instance
   

In Component Browser, select Voltage Sources and then vdc
In the DC voltage field, enter “5 V”
Place it in the Schematic Window

 

H. Place vpulse instance
    

In Component Browser, select Voltage_Sources and then vpulse
    Enter the values as shown in the following form (next page)

Place it in the Schematic Window
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I. Place cap instance
      

In Component Browser, select R_L_C  and then cap
      In the Capacitance field, enter “OutCap F”

(This Design Variable will be used in Artist.)

Place it in the Schematic Window

J. Place wires

In the Schematic Window menu, select Add -> Wire (narrow)
Place the wire to connect all the instances

         Select Design -> Check and Save.  CIW will report any errors.
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Your schematic should look like the one shown below.
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4. Set up the Simulation Environment
 
You are now prepared to simulate your circuit.

From the Schematic Window menu, select Tools -> Analog Environment
A window will pop-up. This window is the Analog Artist Simulation Window.

A. Choose a Simulator

    From the Analog Artist menu, select Setup -> Simulator/Directory/Host.
Enter the fields as shown below.
Choose hspiceS as your simulator.
Your simulation will run in the specified Project Directory.
You may choose any valid pathname and filename that you like.
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B. Choose Analysis
       

We will do Transient Analysis on the circuit that we just produced.

     From the Analog Artist menu, select Analyses -> Choose...
Fill out the form as follows:

C. Add a Variable
   

From the Analog Artist menu, select Variables -> Edit
The Editing Design Variables form will appear.
Fill out the form as shown below, and then click Add to send this Variable to the Table of
Design Variables.

(We entered the OutCap Design Variable in section 3.I.)
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D. Setup Output
      

When using Transient Analysis, the transient voltage will be saved automatically.
We can save the current through capacitor C0 in the schematic by doing the following:

      From the Analog Artist menu, select
Outputs -> To be Saved -> Select On Schematic 

In the Schematic Window, click on the lower terminal (not the wire) of capacitor C0.

After you click on the terminal, the Analog Artist Window should look like this:
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5. Run Simulation
   
From the Analog Artist menu, select Simulation -> Run,
Look at the echoing information in the CIW window.
If the simulation succeeds, the window will display “...successful.”
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6. View Waveforms

From the Analog Artist menu, select
Results -> Direct Plot -> Transient Signal

The Waveform Window will then pop up

In the Schematic Window,
Click on the IN wire and then Click on the OUT wire

Press ESC on your keyboard

The two curves (IN and OUT) will then be displayed in this window:
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Press the Switch Axis Mode icon (circled in Red) on the left side of the Waveform Window

The waveforms will then be displayed separately as shown below: 
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7. Use Calculator

In Artist Window, go to Tools -> Calculator.
The Calculator Window will then pop up, as shown below:

In Calculator Window, go to Options -> Set Algebraic

We are going to use the calculator to plot both the current through the capacitor and the absolute
value of the capacitor current.
 

In Waveform Window, select Window -> Reset to clear the input and output plots from
the window.

In the Calculator Window, click on the it button (3rd column of buttons on the top).
In the Schematic Window, click on the lower terminal of the capacitor.
Returning to the Calculator Window, the text area at the top should like this:
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In the Calculator Window, press the plot button to plot this waveform in the Waveform
Window.

In the Waveform Window, press the Add Subwindow button (bottom button on left).
In the Calculator Window, press the clear button (4th Column, top) to erase the text area,

press the abs button (last column, top), and press the it button.
In the Schematic Window, click on the lower terminal of the capacitor.
Returning to the Calculator Window, the text area at the top should like this:

In the Calculator Window, press the plot button to plot this waveform in the Waveform
Window.
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Your Waveform Window should now look like this:

 

8. Use Results Browser
   
In Artist Window menu, select  Tools -> Result Browser
In the pop-up window that appears, click OK
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The Results Browser Window will then be displayed

 

In Results Browser Window, click netlist/  and then click hspiceFinal

 A text window will then show the hspice netlist file for your circuit.
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This is the end of the tutorial.  On the last few pages we’ve added an extra section on using a
PWL (piece wise linear) voltage source instead of a pulse source, for your edification.  Our
thanks go to Guorong Ma (gma2@unity.ncsu.edu) for writing the original version of this tutorial,
which we have edited to bring to you.  If there are any questions, please email either one of us:

ravett@eos.ncsu.edu
mwbaker@eos.ncsu.edu

Thanks,

Ryan and Matt – Everyone’s favorite ECE 746 TA’s
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Appendix:

9. Using PWL voltage sources.

Assuming you have gone through the previous tutorial and have successfully built your
inverter, we will now show you how to use a PWL voltage source instead of the pulse source
that the tutorial source.  A PWL voltage source is a source whose output voltage is dependant
on a list of time and voltage pairs that is set by the designer.  This list defines what the output
voltage should be at the given times, with the voltage being linearly interpolated between
these points.  This allows a designer to simulate things like digital input streams.

First, we must remove the old pulse source:
In the Schematic Window, click on the pulse source object

 
Then click on the delete button to remove it (the pencil eraser icon)

Now from the Schematic Window menu, select Add -> Instance…
The Component Browser should now pop up, like so:
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In Component Browser, select Voltage_Sources and then vpwl.
The Add Instance Window should now look something like this:
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While this option list looks very intimidating, we are really only concerned with a few of
these many options.

The most important parts of this list are the “Number of pairs of points”, which
specifies how many (time, voltage) pairs you will be defining for this source, and the “Time
X” and “Voltage X” entries where you actually define the point list.

For this tutorial we will do a simple 10-point list:

In the Add Instance Window, fill in the “Number of pairs of points” entry box
with “10”.

When the Add Instance Window finishes updating itself, fill in the time and voltage boxes
with the following:
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In the Schematic Window, add the source instance in the vacant spot left from where we
removed the pulse source.

In the Schematic Window, click the Check and Save button, and fix any errors it
highlights.

Your schematic should look something like this:
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Now we need to test our new circuit to see the PWL source in action.

In Analog Artist Window, double-click on the entry highlighted below, which we set during
the tutorial.

In the window that pops up, change the transient analysis so that it runs for 30 ns, like shown
here:
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Now, we can run the simulation just like we did in the tutorial.  The plot in the Waveform
Window should look like this:

Congratulations!  You’ve just used a PWL voltage source.


